Run of fresh-releases for hcxdumptool

Try this locally package):

debcheckout hcxdumptool
cd hcxdumptool
DEB_UPDATE_CHANGELOG=auto deb-new-upstream --debian-revision=0kali1 --require-uscan --refresh-patches
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
[2022-04-11 09:21:07] Opening branch at https://gitlab.com/kalilinux/packages/hcxdumptool.git/,branch=kali%2Fmaster
[2022-04-11 09:21:08] Using cached branch https://janitor.kali.org/git/hcxdumptool/,branch=kali%2Flatest
[2022-04-11 09:21:13] Total 676 (delta 596), reused 0 (delta 0)
[2022-04-11 09:21:16] Total 2 (delta 0), reused 0 (delta 0), pack-reused 2
[2022-04-11 09:21:20] Total 6 (delta 0), reused 0 (delta 0), pack-reused 6
[2022-04-11 09:21:23] Workspace ready - starting.
[2022-04-11 09:21:23] Running ['deb-new-upstream', '--debian-revision=0kali1', '--require-uscan', '--refresh-patches']
[2022-04-11 09:21:23] Assuming changelog needs to be updated, since it is always changed together with other files in the tree.
Using upstream branch https://github.com/anthonyhseb/googlesearch.git (guessed)
3), done.
Total 134 (delta 25), reused 21 (delta 8), pack-reused 81
Using version string 6.2.5.
No upstream upstream-revision format specified, trying tag:5.1.4
No upstream upstream-revision format specified, trying tag:hcxdumptool-5.1.4
No upstream upstream-revision format specified, trying tag:v5.1.4
No upstream upstream-revision format specified, trying tag:v.5.1.4
No upstream upstream-revision format specified, trying tag:release-5.1.4
No upstream upstream-revision format specified, trying tag:5_1_4_release
No upstream upstream-revision format specified, trying tag:5_1_4
No upstream upstream-revision format specified, trying tag:version-5.1.4
No upstream upstream-revision format specified, trying tag:hcxdumptool-5_1_4-release
No upstream upstream-revision format specified, trying tag:hcxdumptool-v5.1.4
Old upstream version '5.1.4' is not present in upstream branch <UpstreamBranchSource for 'https://github.com/anthonyhseb/googlesearch.git/'>. Unable to determine whether upstream history is normally included. Assuming no.
Using uscan to look for the upstream tarball.
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Devscripts/Uscan/WatchLine.pm line 868.
uupdate: debian/source/format is "3.0 (quilt)".
uupdate: Auto-generating hcxdumptool_5.1.4-0kali1.debian.tar.xz
uupdate: -> Copy to      hcxdumptool_6.2.5-1.debian.tar.xz
Imported hcxdumptool_6.2.5.orig.tar.gz with pristine-tar.
All changes applied successfully.
Committing to: /home/janitor/tmp/janitorji27mjyb/hcxdumptool/
modified Makefile
modified README.md
modified changelog
modified debian/changelog
added docs/config.txt
added docs/first_steps.txt
modified docs/gpiowait.odg
modified hcxdumptool.c
modified hcxpioff.c
modified include/hcxdumptool.h
modified include/ieee80211.h
modified include/pcap.c
modified include/pcap.h
added include/rpigpio.h
modified include/strings.c
deleted include/version.h
modified include/wireless-lite.h
modified license.txt
added man
added man/hcxdumptool.1
modified usefulscripts/bash_profile
modified usefulscripts/piwritecard
Committed revision 5.
Merged new upstream version 6.2.5 (previous: 5.1.4)
Refresh quilt patches.
An error occurred refreshing quilt patch fix-spelling-errors.patch: 

Applying patch debian/patches/fix-spelling-errors.patch
patching file hcxdumptool.c
Hunk #1 FAILED at 4436.
Hunk #2 FAILED at 4477.
Hunk #3 FAILED at 4737.
Hunk #4 FAILED at 4757.
Hunk #5 FAILED at 4867.
Hunk #6 FAILED at 4887.
6 out of 6 hunks FAILED -- rejects in file hcxdumptool.c
Patch debian/patches/fix-spelling-errors.patch does not apply (enforce with -f)

Full worker log