Run of fresh-releases for pylnk

Try this locally package):

debcheckout pylnk
cd pylnk
new-upstream --debian-revision=0kali1 --require-uscan --refresh-patches
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
[2021-05-27 15:09:06] Running ['new-upstream', '--debian-revision=0kali1', '--require-uscan', '--refresh-patches']
[2021-05-27 15:09:06] Opening branch at https://gitlab.com/kalilinux/packages/pylnk.git/,branch=kali%2Fmaster
[2021-05-27 15:09:38] Cached branch URL https://janitor.kali.org/git/pylnk,branch=kali%2Flatest unavailable: Unexpected HTTP status 502 for https://janitor.kali.org/git/pylnk/info/refs?service=git-upload-pack: Unable to handle http code: Bad Gateway
[2021-05-27 15:09:39] 12/28)
[2021-05-27 15:09:39] (16/28)
[2021-05-27 15:09:39] Total 88 (delta 10), reused 17 (delta 4), pack-reused 50
[2021-05-27 15:09:41] Total 12 (delta 3), reused 7 (delta 2), pack-reused 0
[2021-05-27 15:09:43] 5/15), done.
Compressing objects:  16% (1/6)
Compressing objects:  33% (2/6)
Compressing objects:  50% (3/6)
Compressing objects
[2021-05-27 15:09:43] Total 12 (delta 2), reused 10 (delta 2), pack-reused 0
[2021-05-27 15:09:43] Workspace ready - starting.
[2021-05-27 15:09:43] Using upstream branch https://github.com/strayge/pylnk.git (from configuration)
[2021-05-27 15:09:43] 0/157)
[2021-05-27 15:09:43] Total 167 (delta 89), reused 112 (delta 55), pack-reused 10
[2021-05-27 15:09:44] Using version string 0.4.2.
[2021-05-27 15:09:44] Old upstream version '0.2.1+git20200104' is not present in upstream branch <UpstreamBranchSource for 'https://github.com/strayge/pylnk.git/'>. Unable to determine whether upstream history is normally included. Assuming no.
[2021-05-27 15:09:44] Using uscan to look for the upstream tarball.
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Devscripts/Uscan/WatchLine.pm line 868.
[2021-05-27 15:09:49] Searching for revision importing pylnk version 0.2.1+git20200104 on branch upstream, packaging branch.
[2021-05-27 15:09:49] Upstream import of 0.2.1+git20200104 lacks a tag. Set one by running: brz tag -rrevid:git-v1:f797b16281c9a2d332cf56361d938a6d3ec443d2 upstream/0.2.1+git20200104
[2021-05-27 15:09:57] Upstream version 0.4.2 (upstream/0.4.2) is older than current tip.
[2021-05-27 15:10:00] Imported pylnk_0.4.2.orig.tar.gz with pristine-tar.
[2021-05-27 15:10:09] All changes applied successfully.
gbp:info: Changelog last touched at 'e0ae8e24ce8c0e6424d3a18ee793dc5ffdd4a871'
[2021-05-27 15:10:09] Changelog last touched at 'e0ae8e24ce8c0e6424d3a18ee793dc5ffdd4a871'
[2021-05-27 15:10:14] Committing to: /home/janitor/tmp/janitorlvth4cao/pylnk/
[2021-05-27 15:10:14] deleted .gitignore
[2021-05-27 15:10:14] deleted LICENSE
[2021-05-27 15:10:14] added PKG-INFO
[2021-05-27 15:10:14] modified README.md
[2021-05-27 15:10:14] modified debian/changelog
[2021-05-27 15:10:14] renamed pylnk.py => pylnk3.py
[2021-05-27 15:10:14] added pylnk3.egg-info
[2021-05-27 15:10:14] added pylnk3.egg-info/PKG-INFO
[2021-05-27 15:10:14] added pylnk3.egg-info/SOURCES.txt
[2021-05-27 15:10:14] added pylnk3.egg-info/dependency_links.txt
[2021-05-27 15:10:14] added pylnk3.egg-info/entry_points.txt
[2021-05-27 15:10:14] added pylnk3.egg-info/top_level.txt
[2021-05-27 15:10:14] added setup.cfg
[2021-05-27 15:10:14] modified setup.py
[2021-05-27 15:10:15] Committed revision 10.
[2021-05-27 15:10:15] Merged new upstream version 0.4.2 (previous: 0.2.1+git20200104)
[2021-05-27 15:10:15] Opened schroot session kali-dev-amd64-sbuild-2dc475e6-c65e-4b49-bd26-301c74a58c13 (from kali-dev-amd64-sbuild)
[2021-05-27 15:10:16] Using fixers: [PgBuildExtOutOfDateControlFixer(), SimpleBuildFixer(MissingConfigure, fix_missing_configure), SimpleBuildFixer(MissingAutomakeInput, fix_missing_automake_input), SimpleBuildFixer(MissingConfigStatusInput, fix_missing_config_status_input), SimpleBuildFixer(MissingPerlFile, fix_missing_makefile_pl), SimpleBuildFixer(DebcargoUnacceptablePredicate, coerce_unacceptable_predicate), DependencyBuildFixer(AptFetchFailure, retry_apt_failure), PackageDependencyFixer(AptResolver(<ognibuild.debian.apt.AptManager object at 0x7f0ba84b25c0>, [functools.partial(<function python_tie_breaker at 0x7f0bb8f3f9d8>, <GitWorkingTree of /home/janitor/tmp/janitorlvth4cao/pylnk>, ''), BuildDependencyTieBreaker('/var/run/schroot/mount/kali-dev-amd64-sbuild-2dc475e6-c65e-4b49-bd26-301c74a58c13'), <function popcon_tie_breaker at 0x7f0ba8ae9ae8>]))]
[2021-05-27 15:10:16] Building debian packages, running 'sbuild -Asv --dpkg-file-suffix=+jan --force-orig-source --source-only-changes'.
[2021-05-27 15:22:56] Built ['pylnk_0.4.2-0kali1~jan+nur61_amd64+jan.changes', 'pylnk_0.4.2-0kali1~jan+nur61_source.changes'].
janitor.debian.lintian:info: Running lintian
[2021-05-27 15:22:57] Running lintian
[2021-05-27 15:23:02] Pushing result branch to RemoteVcsManager('https://janitor.kali.org/')

Summary

new-upstream --debian-revision=0kali1 --require-uscan --refresh-patches

Full worker log Full build log