Run of fresh-releases for pywerview

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
[2022-01-12 07:30:27] Opening branch at https://gitlab.com/kalilinux/packages/pywerview.git/,branch=kali%2Fmaster
[2022-01-12 07:30:27] Using cached branch https://janitor.kali.org/git/pywerview/,branch=kali%2Flatest
[2022-01-12 07:30:27] Using resume branch: https://janitor.kali.org/git/pywerview,branch=fresh-releases%2Fmain
[2022-01-12 07:30:28] Total 1706 (delta 930), reused 544 (delta 0)
[2022-01-12 07:30:33] Total 1638 (delta 850), reused 561 (delta 0)
[2022-01-12 07:30:36] Total 1634 (delta 871), reused 534 (delta 0)
[2022-01-12 07:30:36] 
[2022-01-12 07:30:36] All changes applied successfully.
[2022-01-12 07:30:39] , done.
[2022-01-12 07:30:39] Total 7 (delta 0), reused 0 (delta 0), pack-reused 2
[2022-01-12 07:30:39] restarting branch
[2022-01-12 07:30:41] All changes applied successfully.
[2022-01-12 07:30:44] Total 7 (delta 0), reused 0 (delta 0), pack-reused 2
[2022-01-12 07:30:47] Total 24 (delta 13), reused 3 (delta 0), pack-reused 0
[2022-01-12 07:30:47] Workspace ready - starting.
[2022-01-12 07:30:47] Running ['deb-new-upstream', '--debian-revision=0kali1', '--require-uscan', '--refresh-patches']
[2022-01-12 07:30:47] Assuming changelog does not need to be updated, since there is a [dch] section in gbp.conf.
Using upstream branch https://github.com/the-useless-one/pywerview.git (from configuration)
Total 1260 (delta 70), reused 65 (delta 37), pack-reused 1157
Using version string 0.3.2.
Old upstream version '0.2.0+git20191220' is not present in upstream branch <UpstreamBranchSource for 'https://github.com/the-useless-one/pywerview.git/'>. Unable to determine whether upstream history is normally included. Assuming no.
Using uscan to look for the upstream tarball.
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Devscripts/Uscan/WatchLine.pm line 868.
uupdate: debian/source/format is "3.0 (quilt)".
uupdate: Auto-generating pywerview_0.2.0+git20191220-0kali2.debian.tar.xz
uupdate: -> Copy to      pywerview_0.3.2-1.debian.tar.xz
Upstream version 0.3.2 (upstream/0.3.2) is older than current tip.
Imported pywerview_0.3.2.orig.tar.gz with pristine-tar.
All changes applied successfully.
Found tag for topmost changelog version '0b98b3335f4a3ec9f2093dc89f141c1a4ee2fd00'
Committing to: /home/janitor/tmp/janitorr5chz4_j/pywerview/
modified README.md
modified debian/changelog
modified pywerview.py
modified pywerview/cli/helpers.py
modified pywerview/cli/main.py
modified pywerview/functions/gpo.py
modified pywerview/functions/hunting.py
modified pywerview/functions/misc.py
modified pywerview/functions/net.py
modified pywerview/objects/adobjects.py
modified pywerview/objects/rpcobjects.py
modified pywerview/requester.py
modified pywerview/worker/hunting.py
modified requirements.txt
modified setup.py
Committed revision 10.
Merged new upstream version 0.3.2 (previous: 0.2.0+git20191220)
Refresh quilt patches.
An error occurred refreshing quilt patch remove-require-pycrypto.patch: 

Applying patch debian/patches/remove-require-pycrypto.patch
patching file setup.py
Hunk #1 FAILED at 30.
1 out of 1 hunk FAILED -- rejects in file setup.py
Patch debian/patches/remove-require-pycrypto.patch does not apply (enforce with -f)

Full worker log

Publish Blockers

  • ☒ run was not successful
  • ☑ package has not been removed from the archive
  • ☒ command changed from DEB_UPDATE_CHANGELOG=auto deb-new-upstream --debian-revision=0kali1 --require-uscan --refresh-patches to deb-new-upstream --debian-revision=0kali1 --require-uscan --refresh-patches --skip-empty
  • ☑ review not required
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☑ proposals not currently being rate-limited for maintainer None
  • ☒ change set 04856458-8f84-440a-b12d-138c350397a4 is working
  • ☑ merge proposals for previous run were not rejected: status.