Run of fresh-releases for ruby-fxruby

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
[2022-03-28 02:21:25] Opening branch at https://gitlab.com/kalilinux/packages/ruby-fxruby.git/,branch=kali%2Fmaster
[2022-03-28 02:21:26] Using cached branch https://janitor.kali.org/git/ruby-fxruby/,branch=kali%2Flatest
[2022-03-28 02:21:28] Total 6403 (delta 723), reused 5680 (delta 0)
[2022-03-28 02:21:28] 
[2022-03-28 02:21:36] Total 5013 (delta 2835), reused 2178 (delta 0)
[2022-03-28 02:21:36] 
[2022-03-28 02:21:41] 63/595)
[2022-03-28 02:21:41] 95)
[2022-03-28 02:21:41] 95)
[2022-03-28 02:21:41] % (584/595)
[2022-03-28 02:21:41] Total 603 (delta 489), reused 594 (delta 488), pack-reused 8
[2022-03-28 02:22:33] All changes applied successfully.
[2022-03-28 02:22:36] Total 19 (delta 1), reused 11 (delta 1), pack-reused 8
[2022-03-28 02:22:39] % (11/11), done.
Compressing objects:   9% (1/11)
Compressing objects:  18% (2/11)
Compressing objects:  27% (3/11)
Compressing 
[2022-03-28 02:22:39] Total 11 (delta 0), reused 11 (delta 0), pack-reused 0
[2022-03-28 02:22:39] Workspace ready - starting.
[2022-03-28 02:22:39] Running ['deb-new-upstream', '--debian-revision=0kali1', '--require-uscan', '--refresh-patches']
[2022-03-28 02:22:39] Assuming changelog does not need to be updated, since there is a [dch] section in gbp.conf.
Using upstream branch https://github.com/larskanis/fxruby.git (from configuration)
Total 6700 (delta 904), reused 969 (delta 876), pack-reused 5673
Using version string 1.6.45.
No upstream upstream-revision format specified, trying tag:1.6.44
No upstream upstream-revision format specified, trying tag:ruby-fxruby-1.6.44
No upstream upstream-revision format specified, trying tag:v1.6.44
Not including upstream history, since previous upstream version (1.6.44) is not present in packaging branch history.
Using uscan to look for the upstream tarball.
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Devscripts/Uscan/WatchLine.pm line 868.
Imported ruby-fxruby_1.6.45.orig.tar.gz with pristine-tar.
Traceback (most recent call last):
  File "/opt/janitor/breezy-debian/scripts/deb-new-upstream", line 1315, in main
    require_uscan=args.require_uscan,
  File "/opt/janitor/breezy-debian/scripts/deb-new-upstream", line 1024, in merge_upstream
    files_excluded=files_excluded,
  File "/opt/janitor/breezy-debian/merge_upstream.py", line 179, in do_merge
    committer=committer, files_excluded=files_excluded)
  File "/opt/janitor/breezy-debian/import_dsc.py", line 1347, in merge_upstream
    merge_type=merge_type)
  File "/opt/janitor/breezy/breezy/workingtree.py", line 681, in merge_from_branch
    conflicts = merger.do_merge()
  File "/opt/janitor/breezy/breezy/merge.py", line 670, in do_merge
    merge = self._do_merge_to()
  File "/opt/janitor/breezy/breezy/merge.py", line 633, in _do_merge_to
    merge.do_merge()
  File "/opt/janitor/breezy/breezy/merge.py", line 774, in do_merge
    self._compute_transform()
  File "/opt/janitor/breezy/breezy/merge.py", line 824, in _compute_transform
    self._finish_computing_transform()
  File "/opt/janitor/breezy/breezy/merge.py", line 834, in _finish_computing_transform
    lambda t, c: transform.conflict_pass(t, c, self.other_tree))
  File "/opt/janitor/breezy/breezy/transform.py", line 905, in resolve_conflicts
    raise MalformedTransform(conflicts=conflicts)
breezy.transform.MalformedTransform: Tree transform is malformed [('unversioned executability', 'new-8'), ('unversioned executability', 'new-12'), ('unversioned executability', 'new-15'), ('unversioned executability', 'new-19'), ('unversioned executability', 'new-22'), ('unversioned executability', 'new-25'), ('unversioned executability', 'new-28'), ('unversioned executability', 'new-31'), ('unversioned executability', 'new-36'), ('unversioned executability', 'new-39'), ('unversioned executability', 'new-42'), ('unversioned executability', 'new-45'), ('unversioned executability', 'new-48'), ('unversioned executability', 'new-51'), ('unversioned executability', 'new-54'), ('unversioned executability', 'new-57'), ('unversioned executability', 'new-60'), ('unversioned executability', 'new-63'), ('unversioned executability', 'new-66')]
Malformed tree transform during new upstream merge
Full worker log

Publish Blockers

  • ☒ run was not successful
  • ☑ package has not been removed from the archive
  • ☒ command changed from DEB_UPDATE_CHANGELOG=auto deb-new-upstream --debian-revision=0kali1 --require-uscan --refresh-patches to deb-new-upstream --debian-revision=0kali1 --require-uscan --refresh-patches --skip-empty
  • ☑ review not required
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☑ proposals not currently being rate-limited for maintainer None
  • ☒ change set 7427118a-565c-4fc8-9869-0f0027b7bd39 is working
  • ☑ merge proposals for previous run were not rejected: status.