Run of fresh-releases for ruby-sha3

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
[2022-11-03 02:16:30] Opening branch at https://gitlab.com/kalilinux/packages/ruby-sha3.git/,branch=kali%2Fmaster
[2022-11-03 02:16:31] Using cached branch file:///home/janitor/vcs/git/ruby-sha3/,branch=kali%2Flatest
[2022-11-03 02:16:38] Total 3 (delta 0), reused 0 (delta 0), pack-reused 0
[2022-11-03 02:16:45] Workspace ready - starting.
Traceback (most recent call last):
  File "/home/janitor/venv/lib/python3.7/site-packages/janitor/worker.py", line 1037, in run_worker
    default_empty=default_empty,
  File "/usr/lib/python3.7/contextlib.py", line 112, in __enter__
    return next(self.gen)
  File "/home/janitor/venv/lib/python3.7/site-packages/janitor/worker.py", line 695, in process_package
    build_target.validate(ws.local_tree, subpath, build_config)
  File "/home/janitor/venv/lib/python3.7/site-packages/janitor/worker.py", line 373, in validate
    from .debian.validate import validate_from_config, ValidateError
  File "/home/janitor/venv/lib/python3.7/site-packages/janitor/debian/validate.py", line 20, in <module>
    from breezy.plugins.debian.vcs_up_to_date import (
ModuleNotFoundError: No module named 'breezy.plugins.debian'
Full worker log

Publish Blockers

  • ☒ run was not successful
  • ☑ package has not been removed from the archive
  • ☒ command changed from deb-new-upstream --debian-revision=0kali1 --require-uscan --refresh-patches to deb-new-upstream --debian-revision=0kali1 --require-uscan --refresh-patches --skip-empty
  • ☑ review not required
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☑ proposals not currently being rate-limited for maintainer None
  • ☒ change set 34554fd5-b495-41ce-80d1-b17c94c4d7ef is working
  • ☑ no relevant previous merge proposals