Run of fresh-snapshots for wordlistraider

Merge these changes:

git pull https://janitor.kali.org/git/wordlistraider fresh-snapshots/pristine-tar
git pull https://janitor.kali.org/git/wordlistraider fresh-snapshots/upstream
Full worker log

Summary

Merged new upstream version: 1.0~git20201208 (was: 1.0~git20200927).

Diff

Branch: pristine-tar

diff --git a/wordlistraider_1.0~git20201208.orig.tar.gz.delta b/wordlistraider_1.0~git20201208.orig.tar.gz.delta
new file mode 100644
index 0000000..ebe7037
Binary files /dev/null and b/wordlistraider_1.0~git20201208.orig.tar.gz.delta differ
diff --git a/wordlistraider_1.0~git20201208.orig.tar.gz.id b/wordlistraider_1.0~git20201208.orig.tar.gz.id
new file mode 100644
index 0000000..e82efd1
--- /dev/null
+++ b/wordlistraider_1.0~git20201208.orig.tar.gz.id
@@ -0,0 +1 @@
+306a4ca5474f88389dc413ad6736477050429ab4

Branch: upstream

Tag: upstream/1.0~git20201208
diff --git a/WordlistRaider.py b/WordlistRaider.py
index d8afc9d..aec43e2 100644
--- a/WordlistRaider.py
+++ b/WordlistRaider.py
@@ -1,3 +1,4 @@
+#!/usr/bin/env python3
 import os
 import sys
 import argparse
@@ -47,4 +48,4 @@ def hasNumbers(inputString):
 def hasSpecialCharacters(inputString):
     return bool(re.findall('[^A-Za-z0-9]',inputString))
 
-process_line_by_line()
\ No newline at end of file
+process_line_by_line()
diff --git a/requirements.txt b/requirements.txt
index 1a46f7f..70ff335 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,12 +1,3 @@
-atomicwrites==1.4.0
-attrs==20.1.0
-colorama==0.4.3
-iniconfig==1.0.1
-more-itertools==8.5.0
-packaging==20.4
-pluggy==0.13.1
-py==1.9.0
-pyparsing==2.4.7
-pytest==6.0.1
-six==1.15.0
-toml==0.10.1
+colorama>=0.4.3
+more_termcolor
+pyfiglet
diff --git a/setup.py b/setup.py
index 81f69cb..db073af 100644
--- a/setup.py
+++ b/setup.py
@@ -8,21 +8,10 @@ setup(
     version='1.0',
     python_requires='>=3.7',
     install_requires=[
-        "atomicwrites==1.4.0",
-        "attrs==20.1.0",
         "colorama==0.4.3",
-        "iniconfig==1.0.1",
-        "more-itertools==8.5.0",
-        "packaging==20.4",
-        "pluggy==0.13.1",
-        "py==1.9.0",
-        "pyparsing==2.4.7",
-        "pytest==6.0.1",
-        "six==1.15.0",
-        "toml==0.10.1"
+        "more_termcolor",
+        "pyfiglet"
     ],
-    packages=find_packages()+['.'],
-    include_package_data=True,
     url='https://github.com/GregorBiswanger/WordlistRaider',
     license='MIT',
     description='Returns a selection of words that matches the passed conditions in an existing list.',
@@ -33,9 +22,5 @@ setup(
         "Operating System :: OS Independent",
     ],
     keywords='wordlist passwordlist cutter raider',
-    entry_points={
-        'console_scripts': [
-            'wordlistraider = wordlistraider.wordlistraider',
-        ],
-    },
+    scripts=['WordlistRaider.py'],
 )

Publish Blockers

  • ☑ run was successful
  • ☑ package has not been removed from the archive
  • ☒ command changed from new-upstream --snapshot --import-only to deb-new-upstream --snapshot --debian-revision=0kali1 --refresh-patches --skip-empty
  • ☑ review not required
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☑ proposals not currently being rate-limited for maintainer None
  • ☑ change set c2ed6138-900b-4295-b5e6-6ed8639c3816 is ready
  • ☑ no relevant previous merge proposals