Codebase list dnscat2 / f87086ae-7c2e-4918-9615-ea2f78837d4a/main debian / patches / keep-upstream-CFLAGS.patch
f87086ae-7c2e-4918-9615-ea2f78837d4a/main

Tree @f87086ae-7c2e-4918-9615-ea2f78837d4a/main (Download .tar.gz)

keep-upstream-CFLAGS.patch @f87086ae-7c2e-4918-9615-ea2f78837d4a/mainraw · history · blame

From: Sophie Brun <[email protected]>
Date: Tue, 25 Aug 2020 15:31:23 +0200
Subject: Keep the upstream CFLAGS

Last-Update: 2020-08-25


We need to have at least the FLAGS --std=c89 -I. for the build.
---
 client/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/client/Makefile b/client/Makefile
index 297bc92..20913ef 100644
--- a/client/Makefile
+++ b/client/Makefile
@@ -9,7 +9,7 @@
 CC?=gcc
 DEBUG_CFLAGS?=-DTESTMEMORY -Werror -O0
 RELEASE_CFLAGS?=-Os
-CFLAGS?=--std=c89 -I. -Wall -D_DEFAULT_SOURCE -fstack-protector-all -Wformat -Wformat-security -g
+CFLAGS+=--std=c89 -I. -Wall -D_DEFAULT_SOURCE -fstack-protector-all -Wformat -Wformat-security -g
 LIBS=-pie -Wl,-z,relro,-z,now
 
 OBJS=controller/packet.o \