Codebase list google-nexus-tools / bc811be3-6966-41cb-b2f5-684569ab2187/main debian / rules
bc811be3-6966-41cb-b2f5-684569ab2187/main

Tree @bc811be3-6966-41cb-b2f5-684569ab2187/main (Download .tar.gz)

rules @bc811be3-6966-41cb-b2f5-684569ab2187/mainraw · history · blame

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

%:
	dh $@

DEB_HOST_ARCH           ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)

ifeq ($(DEB_HOST_ARCH),armel)
	adbbinfile=bin/linux-arm-adb
	fastbootbinfile=bin/linux-arm-fastboot

else ifeq ($(DEB_HOST_ARCH),armhf)
	adbbinfile=bin/linux-arm-adb
	fastbootbinfile=bin/linux-arm-fastboot
else
	adbbinfile=bin/linux-i386-adb
	fastbootbinfile=bin/linux-i386-fastboot
endif

override_dh_auto_install:
	dh_installdirs
	install $(adbbinfile) $(CURDIR)/debian/google-nexus-tools/usr/bin/nexus-adb
	install $(fastbootbinfile) $(CURDIR)/debian/google-nexus-tools/usr/bin/nexus-fastboot

override_dh_strip:
override_dh_shlibdeps: