Codebase list i3-gaps / 357279a debian / patches / Use-correct-shebang-for-perl-scripts.patch
357279a

Tree @357279a (Download .tar.gz)

Use-correct-shebang-for-perl-scripts.patch @357279araw · history · blame

From: =?utf-8?q?Rapha=C3=ABl_Hertzog?= <[email protected]>
Date: Wed, 22 Jul 2020 12:26:10 +0200
Subject: Use correct shebang for perl scripts

Forwarded: not-needed
---
 contrib/dump-asy.pl             | 2 +-
 contrib/gtk-tree-watch.pl       | 2 +-
 contrib/i3-wsbar                | 2 +-
 contrib/per-workspace-layout.pl | 2 +-
 i3-dmenu-desktop                | 2 +-
 i3-migrate-config-to-v4         | 2 +-
 i3-save-tree                    | 2 +-
 7 files changed, 7 insertions(+), 7 deletions(-)

diff --git a/contrib/dump-asy.pl b/contrib/dump-asy.pl
index 5af4c72..b1af5b8 100755
--- a/contrib/dump-asy.pl
+++ b/contrib/dump-asy.pl
@@ -1,4 +1,4 @@
-#!/usr/bin/env perl
+#!/usr/bin/perl
 # vim:ts=4:sw=4:expandtab
 
 use strict;
diff --git a/contrib/gtk-tree-watch.pl b/contrib/gtk-tree-watch.pl
index 30cc64f..8e8ed09 100755
--- a/contrib/gtk-tree-watch.pl
+++ b/contrib/gtk-tree-watch.pl
@@ -1,4 +1,4 @@
-#!/usr/bin/env perl
+#!/usr/bin/perl
 # vim:ts=4:sw=4:expandtab
 # renders the layout tree using asymptote
 
diff --git a/contrib/i3-wsbar b/contrib/i3-wsbar
index a485c15..6b99b93 100755
--- a/contrib/i3-wsbar
+++ b/contrib/i3-wsbar
@@ -1,4 +1,4 @@
-#!/usr/bin/env perl
+#!/usr/bin/perl
 # vim:ts=4:sw=4:expandtab:ft=perl
 # © 2010 Michael Stapelberg, see LICENSE for license information
 
diff --git a/contrib/per-workspace-layout.pl b/contrib/per-workspace-layout.pl
index 4a2b4b9..90b1343 100644
--- a/contrib/per-workspace-layout.pl
+++ b/contrib/per-workspace-layout.pl
@@ -1,4 +1,4 @@
-#!/usr/bin/env perl
+#!/usr/bin/perl
 # vim:ts=4:sw=4:expandtab
 # © 2012 Michael Stapelberg
 # Licensed under BSD license, see https://github.com/i3/i3/blob/next/LICENSE
diff --git a/i3-dmenu-desktop b/i3-dmenu-desktop
index bb69335..303741d 100755
--- a/i3-dmenu-desktop
+++ b/i3-dmenu-desktop
@@ -1,4 +1,4 @@
-#!/usr/bin/env perl
+#!/usr/bin/perl
 # vim:ts=4:sw=4:expandtab
 #
 # © 2012 Michael Stapelberg
diff --git a/i3-migrate-config-to-v4 b/i3-migrate-config-to-v4
index 5da4e26..4a90558 100755
--- a/i3-migrate-config-to-v4
+++ b/i3-migrate-config-to-v4
@@ -1,4 +1,4 @@
-#!/usr/bin/env perl
+#!/usr/bin/perl
 # vim:ts=4:sw=4:expandtab
 #
 # script to migrate an old config file (i3 < 4.0) to the new format (>= 4.0)
diff --git a/i3-save-tree b/i3-save-tree
index da5e6de..7f41fa0 100755
--- a/i3-save-tree
+++ b/i3-save-tree
@@ -1,4 +1,4 @@
-#!/usr/bin/env perl
+#!/usr/bin/perl
 # vim:ts=4:sw=4:expandtab
 #
 # © 2013 Michael Stapelberg