Codebase list osrframework / 2a83a63 debian / patches / fix-exit-function.patch
2a83a63

Tree @2a83a63 (Download .tar.gz)

fix-exit-function.patch @2a83a63raw · history · blame

Description: Fix exit function
 When you quit osrfconsole by typing exit, you have an error:
 "NameError: global name 'info' is not defined"
Author: Sophie Brun <[email protected]>
Last-Update: 2017-09-05
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/osrframework/osrfconsole.py
+++ b/osrframework/osrfconsole.py
@@ -995,7 +995,7 @@ This is free software, and you are welco
         """
         This command will exit osrfconsole normally.
         """
-        print(info("Exiting..."))
+        print(general.info("Exiting..."))
         sys.exit()