Codebase list poshc2 / 98c26d1 debian / patches / remove-git-usage.patch
98c26d1

Tree @98c26d1 (Download .tar.gz)

remove-git-usage.patch @98c26d1raw · history · blame

From: Sophie Brun <[email protected]>
Date: Wed, 20 May 2020 14:57:22 +0200
Subject: Remove git usage in Help.py

Last-Update: 2020-05-20
Description: we don't run the tool in a git directory, the command
fails every time. So we just display the Version, not the commit.
---
 poshc2/client/Help.py | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)

diff --git a/poshc2/client/Help.py b/poshc2/client/Help.py
index d1a5ac5..f342338 100644
--- a/poshc2/client/Help.py
+++ b/poshc2/client/Help.py
@@ -13,12 +13,7 @@ logopic = Colours.GREEN + r"""
                                         \/     \/          \/         \/
 """
 
-try:
-    commit = subprocess.check_output(["git", "log", "-1", "--format='%h %ci'"]).decode().strip('\n').strip("'")[:-6]
-    banner = Colours.GREEN + r"""          =============== PoshC2 %s (%s) ===============
-""" % (VERSION, commit)
-except Exception:
-    banner = Colours.GREEN + r"""          =============== PoshC2 %s ===============
+banner = Colours.GREEN + r"""          =============== PoshC2 %s ===============
 """ % VERSION
 
 logopic = logopic + banner