Codebase list python-cx-oracle / a706ca1 debian / tests / basic-test.sh
a706ca1

Tree @a706ca1 (Download .tar.gz)

basic-test.sh @a706ca1raw · history · blame

#!/bin/sh

set -e

test_install_python3() {

    echo "Testing python3 package"
    for py in $(py3versions -r 2>/dev/null) ; do
	cd "$AUTOPKGTEST_TMP" ;
	echo "Testing with $py:" ;
	$py -c "import cx_Oracle; print(cx_Oracle)" ;
    done

}

###################################
# Main
###################################

for function in "$@"; do
        $function
done