Codebase list python-faraday / 3c1c6c8 debian / patches / dont-check-update.patch
3c1c6c8

Tree @3c1c6c8 (Download .tar.gz)

dont-check-update.patch @3c1c6c8raw · history · blame

From: Kali Developers <[email protected]>
Date: Tue, 15 Oct 2019 11:09:33 +0200
Subject: Remove unwanted checks

We don't want that user updates with update option: no need to check the

We don't want that user updates with update option: no need to check the
version and to propose updates. We don't need to check if dependencies are
installed: apt does that at the installation.
Author: Sophie Brun <[email protected]>
Forwarded: not-needed
Last-Update: 2021-06-30
---
 faraday/start_server.py | 3 ---
 1 file changed, 3 deletions(-)

diff --git a/faraday/start_server.py b/faraday/start_server.py
index bb84399..4ab2c68 100644
--- a/faraday/start_server.py
+++ b/faraday/start_server.py
@@ -121,7 +121,6 @@ def main():
     check_postgresql()
     parser = argparse.ArgumentParser()
     parser.add_argument('--debug', action='store_true', help='run Faraday Server in debug mode')
-    parser.add_argument('--nodeps', action='store_true', help='Skip dependency check')
     parser.add_argument('--no-setup', action='store_true', help=argparse.SUPPRESS)
     parser.add_argument('--port', type=int, help='Overides server.ini port configuration')
     parser.add_argument('--websocket_port', help='Overides server.ini websocket port configuration')
@@ -144,8 +143,6 @@ def main():
     if result == 0:
         logger.error("Faraday Server port in use. Check your processes and run the server again...")
         sys.exit(1)
-    if not args.no_setup:
-        setup_environment(not args.nodeps)
     if args.websocket_port:
         faraday.server.config.faraday_server.websocket_port = args.websocket_port