Codebase list python-faraday / kali/3.17.1-0kali1 debian / rules
kali/3.17.1-0kali1

Tree @kali/3.17.1-0kali1 (Download .tar.gz)

rules @kali/3.17.1-0kali1raw · history · blame

#!/usr/bin/make -f

#export DH_VERBOSE = 1
export PYBUILD_TEST_ARGS=-k "not TestGetExploits and not test_update_command and not test_start_and_kill_faraday_server and not test_create_agent_without_name_fails and not test_create_agent_invalid_payload and not test_vuln_filter_exception and not test_vuln_restless_sort_by_ and not test_vuln_web_filter_exception and not test_filter_by_creator_command_id and not test_openapi_format and not test_filter_by_querystring and not test_websocket_BroadcastServerProtocol and not test_vuln_filter and not test_yaml_docs_with_no_doc and not test_yaml_docs_with_defaults and not test_tags_sorted_correctly"

%:
	dh $@ --with python3,sphinxdoc --buildsystem=pybuild

override_dh_auto_build:
	dh_auto_build
	PYTHONPATH=. http_proxy='127.0.0.1:9' sphinx-build -N -bhtml doc build/html

override_dh_install:
	dh_install
	# remove unwanted files: .gitignore and useless README
	rm debian/faraday/usr/lib/python3*/dist-packages/faraday/migrations/versions/.gitignore
	rm debian/faraday/usr/lib/python3*/dist-packages/faraday/migrations/README

override_dh_installchangelogs:
	dh_installchangelogs RELEASE.md