Codebase list ruby-fxruby / run/867a9ad8-16f3-49f2-8da1-08141b9b00dd/main debian / patches / fix-path-headers.patch
run/867a9ad8-16f3-49f2-8da1-08141b9b00dd/main

Tree @run/867a9ad8-16f3-49f2-8da1-08141b9b00dd/main (Download .tar.gz)

fix-path-headers.patch @run/867a9ad8-16f3-49f2-8da1-08141b9b00dd/mainraw · history · blame

From: Sophie Brun <[email protected]>
Date: Tue, 8 Mar 2022 12:15:51 +0100
Subject: Fix path header

Last-Update: 2017-02-22

Last-Update: 2017-02-22
---
 ext/fox16_c/FXRbApp.cpp  | 2 +-
 ext/fox16_c/extconf.rb   | 2 +-
 ext/fox16_c/make_impl.rb | 2 +-
 scripts/build-fox.rb     | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)

Index: ruby-fxruby.git/ext/fox16_c/FXRbApp.cpp
===================================================================
--- ruby-fxruby.git.orig/ext/fox16_c/FXRbApp.cpp
+++ ruby-fxruby.git/ext/fox16_c/FXRbApp.cpp
@@ -24,7 +24,7 @@
  * $Id: FXRbApp.cpp 2902 2008-12-11 14:09:20Z lyle $
  ***********************************************************************/
 
-#include "FXRbCommon.h"
+#include "include/FXRbCommon.h"
 
 #ifdef HAVE_SYS_TIME_H
 #include <sys/time.h> /* For struct timeval */
Index: ruby-fxruby.git/ext/fox16_c/extconf.rb
===================================================================
--- ruby-fxruby.git.orig/ext/fox16_c/extconf.rb
+++ ruby-fxruby.git/ext/fox16_c/extconf.rb
@@ -1,4 +1,4 @@
-#!/bin/env ruby
+#!/usr/bin/env ruby
 
 require 'fileutils'
 require 'mkmf'
Index: ruby-fxruby.git/ext/fox16_c/make_impl.rb
===================================================================
--- ruby-fxruby.git.orig/ext/fox16_c/make_impl.rb
+++ ruby-fxruby.git/ext/fox16_c/make_impl.rb
@@ -1,4 +1,4 @@
-#!/bin/env ruby
+#!/usr/bin/env ruby
 
 $special_stubclasses = ["FXGLSHAPE", "FXICONITEM", "FXTABLE", "FXTABLEITEM", "FXTEXT", "FXTREEITEM"]
 
Index: ruby-fxruby.git/scripts/build-fox.rb
===================================================================
--- ruby-fxruby.git.orig/scripts/build-fox.rb
+++ ruby-fxruby.git/scripts/build-fox.rb
@@ -1,4 +1,4 @@
-#!/usr/local/bin/ruby
+#!/usr/bin/ruby
 
 def build_project(topdir, project)
   dspfile = [topdir, 'windows', 'vcpp', project, project + '.dsp'].join(File::ALT_SEPARATOR)