Codebase list ruby-fxruby / run/aa4c1343-5bb9-452f-ab3a-6b23547dc6ea/main debian / patches / do-not-use-git-ls.patch
run/aa4c1343-5bb9-452f-ab3a-6b23547dc6ea/main

Tree @run/aa4c1343-5bb9-452f-ab3a-6b23547dc6ea/main (Download .tar.gz)

do-not-use-git-ls.patch @run/aa4c1343-5bb9-452f-ab3a-6b23547dc6ea/mainraw · history · blame

From: Sophie Brun <[email protected]>
Date: Thu, 10 Mar 2022 15:53:59 +0100
Subject: Do not use git ls in Gemfile

git is not available when we build the package. Use Dir.glob instead of
git ls.
---
 fxruby.gemspec | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

Index: ruby-fxruby.git/fxruby.gemspec
===================================================================
--- ruby-fxruby.git.orig/fxruby.gemspec
+++ ruby-fxruby.git/fxruby.gemspec
@@ -36,9 +36,8 @@ Gem::Specification.new do |spec|
   spec.metadata["changelog_uri"] = "https://github.com/larskanis/fxruby/blob/1.6/History.md"
   spec.metadata["documentation_uri"] = "https://rubydoc.info/gems/fxruby/frames"
 
-  spec.files         = `git ls-files -z`.split("\x0").reject do |f|
-    f=~/^fox-includes|^web/
-  end
+  spec.files         = Dir.glob('*/**')
+  spec.test_files    = spec.files.grep(%r{^(fox-includes|web)/})
   spec.files += SWIG_MODULES.values.map{|f| File.join("ext/fox16_c", f) }
   spec.files << 'ext/fox16_c/include/inlinestubs.h'
   spec.files << 'ext/fox16_c/swigruby.h'