Codebase list sqlsus / 66ad088 debian / patches / drop-defined-array.patch
66ad088

Tree @66ad088 (Download .tar.gz)

drop-defined-array.patch @66ad088raw · history · blame

Description: drop defined in defined(@array)
Author: Sophie Brun <[email protected]>
Bug-Kali: https://bugs.kali.org/view.php?id=3192
Last-Update: 2016-04-06
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/sqlsus
+++ b/sqlsus
@@ -77,7 +77,7 @@ sub save_and_exit {
 ##################################
 sub save {
 	&db::save_vars;
-	if (defined @history or not $interactive) {
+	if (@history or not $interactive) {
 		&db::query("DELETE FROM history");
 		&db::save_history(@history);
 	}