Codebase list uniscan / ae7fb76 debian / patches / fix-for-perl-5-22.patch
ae7fb76

Tree @ae7fb76 (Download .tar.gz)

fix-for-perl-5-22.patch @ae7fb76raw · history · blame

From: Kali Developers <[email protected]>
Date: Mon, 18 Jan 2021 15:57:54 +0100
Subject: Fix to work with Perl 5.22.2-5

Origin: other, https://bugs.kali.org/view.php?id=3608
Bug-Kali: https://bugs.kali.org/view.php?id=3608
Last-Update: 2016-09-23

'.' has been removed from @INC by default in Perl 5.22.2-5 in debian
(fixes 588017)
Last-Update: 2016-09-23
---
 uniscan.pl | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/uniscan.pl b/uniscan.pl
index 6955879..5f300d6 100755
--- a/uniscan.pl
+++ b/uniscan.pl
@@ -20,7 +20,8 @@
 #	 Douglas Poerschke Rocha since version 1.0
 
 	
-use lib "./Uniscan";
+use FindBin qw($RealBin);
+use lib $RealBin;
 use Uniscan::Crawler;
 use Uniscan::Functions;
 use Uniscan::Scan;