Codebase list gnome-shell-extensions / 1f56ac4 debian / patches / apps-center-labels.patch
1f56ac4

Tree @1f56ac4 (Download .tar.gz)

apps-center-labels.patch @1f56ac4raw · history · blame

From 79f263d1edbd6f7cfe13cf89933941b439325cee Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <[email protected]>
Date: Wed, 26 Nov 2014 19:03:49 +0100
Subject: apps-menu: Center app labels

Currently labels are not vertically centered, unlike icons.
Fix this.

https://bugzilla.gnome.org/show_bug.cgi?id=740724

diff --git a/extensions/apps-menu/extension.js b/extensions/apps-menu/extension.js
index a8fb74d..f8438fd 100644
--- a/extensions/apps-menu/extension.js
+++ b/extensions/apps-menu/extension.js
@@ -58,7 +58,8 @@ const ApplicationMenuItem = new Lang.Class({
         this._iconBin = new St.Bin();
         this.actor.add_child(this._iconBin);
 
-        let appLabel = new St.Label({ text: app.get_name() });
+        let appLabel = new St.Label({ text: app.get_name(), y_expand: true,
+                                      y_align: Clutter.ActorAlign.CENTER });
         this.actor.add_child(appLabel, { expand: true });
         this.actor.label_actor = appLabel;
 
-- 
cgit v0.10.1