Codebase list google-nexus-tools / 76d1957 debian / rules
76d1957

Tree @76d1957 (Download .tar.gz)

rules @76d1957raw · history · blame

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

%:
	dh $@

DEB_HOST_ARCH           ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)

ifeq ($(DEB_HOST_ARCH),armel)
	adbbinfile=bin/linux-arm-adb
	fastbootbinfile=bin/linux-arm-fastboot

elif ($(DEB_HOST_ARCH),armhf)
        adbbinfile=bin/linux-arm-adb
        fastbootbinfile=bin/linux-arm-fastboot
else
        adbbinfile=bin/linux-i386-adb
        fastbootbinfile=bin/linux-i386-fastboot
endif

override_dh_auto_install:
	dh_installdirs
	install $(adbbinfile) $(CURDIR)/debian/google-nexus-tools/usr/bin/nexus-adb
	install $(fastbootbinfile) $(CURDIR)/debian/google-nexus-tools/usr/bin/nexus-fastboot
	install udev.txt $(CURDIR)/debian/google-nexus-tools/etc/udev/rules.d/51-android.rules