Codebase list i3-gaps / abeb4c4c-35f7-44b3-961f-efafcc45e92a/upstream debian / rules
abeb4c4c-35f7-44b3-961f-efafcc45e92a/upstream

Tree @abeb4c4c-35f7-44b3-961f-efafcc45e92a/upstream (Download .tar.gz)

rules @abeb4c4c-35f7-44b3-961f-efafcc45e92a/upstreamraw · history · blame

#!/usr/bin/make -f
# vi: ts=8 sw=8 noet

export V:=1
export DEB_BUILD_MAINT_OPTIONS = hardening=+all

override_dh_installchangelogs:
	dh_installchangelogs RELEASE-NOTES-*

override_dh_strip:
	dh_strip --dbg-package=i3-wm-dbg

override_dh_auto_test:
	# TODO: enable tests

override_dh_auto_configure:
	# Set -Ddocdir; the default is /usr/share/doc/i3
	dh_auto_configure -- -Ddocdir=/usr/share/doc/i3-wm -Dmans=true

override_dh_builddeb:
	# bintray does not support xz currently.
	dh_builddeb -- -Zgzip

%:
	dh $@ --buildsystem=meson