Codebase list i3-gaps / e79825a3-9771-4a6a-8d65-c1f42f790b71/main debian / rules
e79825a3-9771-4a6a-8d65-c1f42f790b71/main

Tree @e79825a3-9771-4a6a-8d65-c1f42f790b71/main (Download .tar.gz)

rules @e79825a3-9771-4a6a-8d65-c1f42f790b71/mainraw · history · blame

#!/usr/bin/make -f

# vi: ts=8 sw=8 noet

export V:=1
export DEB_BUILD_MAINT_OPTIONS = hardening=+all

execute_after_dh_auto_install:
	# Some files are not installed in docdir
	mv -v debian/tmp/usr/share/doc/i3/* debian/tmp/usr/share/doc/i3-gaps-wm/
	rmdir -v debian/tmp/usr/share/doc/i3/

override_dh_installchangelogs:
	dh_installchangelogs RELEASE-NOTES-*

override_dh_auto_test:
#	mv testcases/t/533-randr15.t testcases/t/533-randr15.t.disabled
#	dh_auto_test
#	mv testcases/t/533-randr15.t.disabled testcases/t/533-randr15.t
#	disable tests as they fail on most arch

override_dh_auto_configure:
	# Set -Ddocdir; the default is /usr/share/doc/i3
	dh_auto_configure -- -Ddocdir=/usr/share/doc/i3-gaps-wm -Ddocs=true -Dmans=true

%:
	dh $@ --builddirectory=build --buildsystem=meson