Codebase list i3-gaps / cd6f42e debian / rules
cd6f42e

Tree @cd6f42e (Download .tar.gz)

rules @cd6f42eraw · history · blame

#!/usr/bin/make -f
# vi: ts=8 sw=8 noet

export V:=1
export DEB_BUILD_MAINT_OPTIONS = hardening=+all

execute_after_dh_auto_install:
	# Some files are not installed in docdir
	mv -v debian/tmp/usr/share/doc/i3/* debian/tmp/usr/share/doc/i3-gaps-wm/
	rmdir -v debian/tmp/usr/share/doc/i3/

override_dh_installchangelogs:
	dh_installchangelogs RELEASE-NOTES-*

override_dh_auto_test:
#	mv testcases/t/533-randr15.t testcases/t/533-randr15.t.disabled
#	dh_auto_test
#	mv testcases/t/533-randr15.t.disabled testcases/t/533-randr15.t
#	disable tests as they fail on most arch

override_dh_auto_configure:
	# Set -Ddocdir; the default is /usr/share/doc/i3
	dh_auto_configure -- -Ddocdir=/usr/share/doc/i3-gaps-wm -Ddocs=true -Dmans=true

%:
	dh $@ --builddirectory=build --buildsystem=meson